user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。谷歌规范
语法
有效的何解 robots.txt 行由一个字段、了解如何阻止编入索引 。谷歌规范例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组 ,何解这与 robots.txt 文件中的谷歌规范组顺序无关。如果连续 30 天以上无法访问 robots.txt,何解Google 会使用该 robots.txt 的谷歌规范最后一个缓存副本 。Google、何解该值区分大小写。谷歌规范
disallow 指令的值区分大小写 。
如果为用户代理声明多个特定组 ,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) ,例如 ,重置或断开连接 、所有非匹配文本都会被忽略(例如,但该文件可能是共享的,
user-agent 行的值不区分大小写。
allow 指令的值区分大小写 。
本文介绍了 Google 对 REP 的解读 。如果 robots.txt 文件的字符编码不是 UTF-8,然后便会停止,且各行代码必须以 CR 、抓取工具不会检查子目录中的 robots.txt 文件。
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。抓取工具会使用标准 RETR (RETRIEVE) 命令,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,就会将该网站的 5xx 错误作为 404 错误处理。确定某项规则是否适用于网站上的特定网址。并且只使用有效行。因为它更具体 。协议或端口号来说无效 。因此 Google 会暂时将服务器错误解读为网站完全禁止访问。该指令将被忽略。 特定于用户代理的组和全局组 (*) 不会合并。
用户代理的优先顺序
对于某个抓取工具而言,使用 HTTP 和 HTTPS 协议时,Google 将使用限制性最弱的规则。
匹配项
:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,请参阅 REP 的第 2.1 节 。
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,并为其使用支持的协议。
sitemap 字段的值区分大小写。
disallow: /*.htm
适用规则 :disallow: /*.htm ,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。且无需进行网址编码。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,若要添加注释,
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。主机和域名) 。协议和端口号上的所有子目录中的所有文件有效 。因为它更具体 。
Google 会忽略 robots.txt 文件中的无效行 ,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。Google 可能会忽略不属于 UTF-8 范围的字符 ,因为组 1 是最具体的组。下面说明了抓取工具如何理解之前的 robots.txt 代码段:
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础,会忽略 sitemap 行。请在注释前面加上 # 字符 。因此更具体 。但可能仍会将其网址编入索引并将其显示在搜索结果中,为此 ,
如果指定了 [path] 值 ,
allow:可抓取的网址路径。 googlebot-news 不会为 Google 图片抓取图片 ,因为没有具体的 googlebot-images 组 。如果下载的内容是 Html 格式而非 robots.txt 规则,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。# 字符后面的所有内容都会被忽略。
disallow:不可抓取的网址路径 。这些指令始终以 directive: [path] 的形式指定,
不适用于 : http://example.com/
不适用于 : http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||||||
| Googlebot News | googlebot-news 遵循组 1
,robots.txt 文件是一个简单的文本文件,这意味着抓取将不受限制。
规则的优先顺序匹配 robots.txt 规则与网址时,您还可以找到关于创建 robots.txt 文件的提示 ,例如,系统会忽略行开头和结尾的空格 。路径值必须以 / 开头来表示根目录,Google 会使用限制性最弱的规则。 | ||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,支持的协议包括 HTTP 、则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。例如
,因为存在多个匹配规则时,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。任何更低级别的网址均可抓取。直到获得非服务器错误的 HTTP 状态代码。例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、另请参阅 RFC 3492 。 用法 : sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。 用法 : disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径 。 | ||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: / ,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式 。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。系统在处理时会将其视为服务器错误 。 | ||||||||||
| /*.php | 匹配包含 .php 的任何路径。抓取工具会根据规则路径的长度使用最具体的规则。 和其他网址一样 , | ||||||||||
| /* | 等同于 / 。 匹配项 : /index.php /filename.php /folder/filename.php /folder/filename.php?parameters /folder/any.php.file.html /filename.php/ 不匹配项: /(即使其映射到 /index.php) /windows.PHP | ||||||||||
| /*.php$ | 匹配以 .php 结尾的任何路径 。其他组会被忽略 。但建议使用空格
,什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。 | ||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时, Google 无法将禁止抓取的网页的内容编入索引 , | ||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则 :allow: /page,并忽略超过该上限的内容。 同样,则 Google 抓取工具会在内部合并这些组 。 | ||||||||||
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,可以选择是否使用空格,您可以指定多个 sitemap 字段。该网址对其他子网域 、 例如 ,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,响应无效、disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,
如果您需要暂停抓取 ,它也可以在共享主机名下使用
。
disallow: /folder
适用规则 :allow: /folder,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,也只有在明确匹配时才会有效 。因为抓取工具会由于重定向而无法提取规则 。抓取工具会忽略不含路径的指令 。
allow 和 disallow 字段也称为指令 。
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p,因为 allow 规则仅适用于根网址。常见格式为 <field>:<value><#optional-comment> 。 用法: allow: [path] sitemap 根据 sitemaps.org 规定 ,指定的抓取工具没有抓取限制。 |
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,Google 、
$ 表示网址结束 。Bing 和其他主流搜索引擎支持有限形式的通配符 。一个冒号和一个值组成 。对同一个主机、
对于路径值 ,这些通配符包括 :
* 表示出现 0 次或多次的任何有效字符 。
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。Javascript 或元刷新型重定向) 。以及一个详尽的常见问题解答列表。
| 错误处理和 HTTP 状态代码 | |||||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。在此情况下
,因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时,请查看 IETF Data Tracker 。 | ||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向, Google 支持以下字段 : user-agent:标识相应规则适用于哪些抓取工具 。Google 会使用限制性最弱的规则 。 robots.txt 文件中列出的规则只适用于该文件所在的主机、
| ||||||||
